Chrome error: 'ERR_SPDY_PROTOCOL_ERROR


#22

-t says line of ssl_cipher has some issues (basically i had copied the above mentioned ciphers to my ssl.conf and post that nginx would not start)…


#23

please remove the one on ssl.conf and place the ssl_cipher only on nginx.conf


#24

Same error caused to me.

And I replace ssl_cipher with this one

ssl_ciphers 'ECDHE-RSA-AES128-GCM-SHA256:AES256+EECDH:AES256+EDH';

and problem resolved.


#25

Well, Identified the issue deeply and it occurs frequently in Internet Browsers due to some uncommon reasons. I have listed down all the possible solutions and 99% your issue is going to resolve from one of the solution. Try them one by one and do reply which solution solved your issue.

Solutions Page: How to Solve Google Chrome’s Error “ERR_SPDY_PROTOCOL_ERROR"


#26

Try clearing the cache and restart the chrome. I always do this and it works every time. take a look at some more solutions: How To Fix Chrome’s ERR_SPDY_PROTOCOL_ERROR


#27

One of the most common problems that we face while using Google Chrome is the error " ERR_SPDY_PROTOCOL_ERROR ". You may encounter this issue while browsing certain pages on the browser.Refer the artical : ERR_SPDY_PROTOCOL_ERROR


#28

There are many ways to fix this error, You can any one and can fix very easily, Mostly it can fix by

  1. Updating Google Chrome Browser
  2. Flush the Socket Solution
  3. Clear Cookies
  4. Restart Browser If still problem not solve then try manually for more fixes.

#29

Perhaps try to change your current SSL Cipher with these:

https://mozilla.github.io/server-side-tls/ssl-config-generator/


#30

I had one of my sites suddenly go down with a SPDY_PROTOCOL_ERROR, all my other sites were operational so I knew 100% it was nothing to do with any certificate problem.

I eventually traced it to a permissions problem with the location for the nginx fastcgi cache. A simple chown -R www-data:www-data on the /var/cache/nginx folder resolved it for me immediately. Hopefully this may help someone in future.


#31

Hi, Mahendra meghwal Your suggestion really working for me. I find that mostly it is happen due to cookies and also Antivirus. I found also a good site where you can find right fixes. Thanks


#32

This is also happen due to Anti Virus, If you are using Avast Safe sure it will due to this. You can try it via disable.


#33

I am facing this error many times. i jusy found some simple solution to resloved this error here. few normal steps write about here


#34

100% working try this fix


#35

HTTP/2 has a huge blacklist of old and insecure ciphers, so we must avoid them. Try the following configuration, it works for me (EasyEngine v3.8.1 / Ubuntu 18.04 LTS)

ssl_ciphers EECDH+CHACHA20:EECDH+AES128:RSA+AES128:EECDH+AES256:RSA+AES256:EECDH+3DES:RSA+3DES:!MD5;

Working reference: https://www.digitalocean.com/community/tutorials/how-to-set-up-nginx-with-http-2-support-on-ubuntu-16-04


#37

Thank You


#38

Worked perfectly. Thanks!