Ee issue after upgrade


#1

I upgraded my Easyengine setup to 3.6, everythng seemed fine after update. I then upgraded my VPS from Ubuntu 14.04 to 16.04. The website works fine but there some errors whenever I try to do something in “ee” :

Traceback (most recent call last): File “/usr/local/bin/ee”, line 5, in from pkg_resources import load_entry_point File “/usr/lib/python3/dist-packages/pkg_resources/init.py”, line 2927, in @_call_aside File “/usr/lib/python3/dist-packages/pkg_resources/init.py”, line 2913, in _call_aside f(*args, **kwargs) File “/usr/lib/python3/dist-packages/pkg_resources/init.py”, line 2940, in _initialize_master_working_set working_set = WorkingSet._build_master() File “/usr/lib/python3/dist-packages/pkg_resources/init.py”, line 635, in _build_master ws.require(requires) File “/usr/lib/python3/dist-packages/pkg_resources/init.py”, line 943, in require needed = self.resolve(parse_requirements(requirements)) File “/usr/lib/python3/dist-packages/pkg_resources/init.py”, line 829, in resolve raise DistributionNotFound(req, requirers) pkg_resources.DistributionNotFound: The ‘ee==3.6.0’ distribution was not found and is required by the application

Any idea how to fix it or what is causing it?


#2

@Francisc_Furdui Could you share following details with us:

  1. The command you used to upgrade EasyEngine
  2. Content of /var/log/ee/instal.log

#3

I used “ee update” . I can’t seem to copy the log file, or better said I don’t know how, too long to do copy paste from an SSH window. Either way is there no command to reinstall ee or do a check on it?


#4

try cating the log to another file and then you can download that file… so “cat /var/log/ee/install.log > ~/ee-install.log” That should give you an ee-install.log file in your home directory that you can use scp or sftp to download to your local machine.


#5

Same happens for me, expect the last line reads

The ‘ee==3.6.1’ distribution was not found and is required by the application What i did was upgrading 14.04 to 16.04 LTS using the do-release-upgrade. during the upgrade the apt.sources entries for ee where commented out (they point to 14.04 sources anyways).

Before i went to 16.04 i did an ee update to 3.6.1 - everything went fine - and those are actually the last entries in the install.log file. When i try to do a

wget -qO ee rt.cx/ee && sudo bash ee

i get this:

Executing apt-get update, please wait… [ Tue May 24 09:32:03 UTC 2016 ] You already have EasyEngine 3.6.1, exit status = 1

i can not run ee or launch any commands to it.

also the sources are still commented out.

Would love to see a solution, until that - i roll back my snapshot :slight_smile:

Thanks!


What happened to ViMbadmin?
#6

@newuser @Francisc_Furdui You can simply try removing and reinstalling EasyEngine. The command would be:

rm -f `` $(which ee)`` && wget rt.cx/ee && sudo bash ee

The issue is, if you do a dist-upgrade after updating EasyEngine it breaks some of the EasyEngine Python dependency packages resulting in such errors. We are trying to figure the issue out but since the package broken in different scenario is totally different than other, it could take a bit long. Thank you for your patience.

Regards


#7

THANK YOU! This ended up allowing me to recover from this.

Seriously, this risk, and this fix, need to be much more publicized.

Hiding this and making such a critical fix so difficult to find is ridiculous!


#8

This just saved me also - thanks!